Samba

Samba for SLES 8

For SLES 8 (or United Linux 1) Novell provides Samba 2.2.x packages but no support for Samba 3. Packaging, maintenance and support have been delegated to SerNet.


Feature items:

  • Better Kerberos integration. Packages are statically linked against a current version of Heimdal-Kerberos (we additionally support TCP fallback e.g.) to ensure best interoperability with Windows 2003 Active Directory servers.
  • More reliable init scripts. There are some problems in the SuSE init scripts and related tools, which Novell did not fix. Daemons from plain SuSE packages (like some other services, too) are not reliably stopped and not reliably restarted, we do work around this problem in our packages.
  • Prefix "samba3-" so they cannot be updated by native update packages accidently.
  • Support for NTLM authentication also in Active Directory domains if security = domain ist used instead of security = ads.
  • Patches which we consider to be too experimental for production machines are being removed while other patches for problems that we encountered are being added.

Start downloading following your platform link:

Other platforms are available on request.

Latest News

2017-05-24

SAMBA+ Security Releases: 4.6.4, 4.5.10 and 4.4.14 packages available

SAMBA+ 4.6.4, 4.5.10 and 4.4.14 have just been released. These are very important security releases, please update affected systems (Samba 3.5.0 and newer) immediately! The packages are available for various SUSE and Red Hat platforms as well as for Debian GNU/Linux and Ubuntu. Have a look at the SAMBA+ News Section for details on the security impact.

2017-05-18

SAMBA+ 4.5.9 Available for Download

New SAMBA+ 4.5.9 packages have just been released. Packages for various SUSE and Red Hat platforms as well as for Debian GNU/Linux and Ubuntu are available now. Have a look at the release notes for more information.